Starting test names with “itShould” or “should”

Recommended reading before you read this article: Mockito basics, Fest assertions.

Sometimes you might find some people applying a convention of starting test names with a prefix such as “itShould” or “should”, for example:

I used to do it, but now I find it useless. It is unnecessary noise for me. The test name listed below still reads like a sentence (is readable) and has no unnecessary additions.

What do you think?